• Hallo zusammen,

    Ich habe ein Bearbeitungsprogramm, welches über Vectorwop erstellt wurde, darin ist ein NC-Stop zum Drehen einer Mittelseite enthalten.

    Die Maschine fährt auf die Parkposition l+800 und der Vakuum wird gelöst.

    Wir spannen wieder, drücken den Startknopf einmal und die Bohraggregate fangen an zu drehen aber weiter passiert nichts.

    Drücken wir ein weiteres mal Start, beendet die Maschine das Programm, ohne die weiteren Bearbeitungen durchzuführen und verfährt auf die Parkposition nach Programmende. Hat jemand einen Schimmer, woran es liegen kann?

  • Hello!

    I would say that the machine drills all the holes already at the beginning of the program. In other words, drill twice.

    You have drilling optimization turned on (1) in the nc settings, so the machine does all the drilling at the beginning of the program. Set this optimization to off ( 0 ) and the program will work correctly.

    -Sami

  • Hello!

    I would say that the machine drills all the holes already at the beginning of the program. In other words, drill twice.

    You have drilling optimization turned on (1) in the nc settings, so the machine does all the drilling at the beginning of the program. Set this optimization to off ( 0 ) and the program will work correctly.

    -Sami

    It only drills every hole once.

    Changing the optimizsation only changes the order in which does the tasks.

  • Teste das Programm mal. :/

    Leider werden die Bearbeitungen nach dem NC Stop auch hier nicht ausgeführt. Aber die Idee war gut.

    Hatte schon in die gleiche Richtung überlegt. Komischerweise sind die Lochreihen ja mehrfach angelegt werden aber nur jeweils einaml abgearbeitet.

    Edited once, last by woodie (September 20, 2023 at 2:15 PM).

  • Leider werden die Bearbeitungen nach dem NC Stop auch hier nicht ausgeführt. Aber die Idee war gut.

    Hatte schon in die gleiche Richtung überlegt. Komischerweise sind die Lochreihen ja mehrfach angelegt werden aber nur jeweils einaml abgearbeitet.

    Lösche bitte die doppelten Bearbeitungen mal raus, und schaue dann mal ob es passt!

    Viele Grüße
    HomagLove

  • eigentlich müsste Doch eine Hinweis beim NC Stopp kommen , oder?

    Da kommt auch nix

    Klappt der NC-Stop mit anderen Programme? Oder hast du immer das Problem? Je nach Maschine wird es ausgegeben oder auch nicht!

    Kannst mal eine Tasche hinter dem NC-Stop programmieren, und schauen wie sich das verhält!

    Viele Grüße
    HomagLove

  • Hallo,

    Meldungen zeitrichtig ausgeben hat noch nie funktioniert bei Weeke Maschinen, das geht nur mit Tricks. Hatte ich schon mal etwas dazu geschrieben irgend wann.

    Stell bitte einmal das generierte Programm aus dem prg Ordner hier ein. Ich vermute du hast einen veralteten NC-Weeke der hat bei Bohroptimierung den NC-Stop ignoriert. Alternativ kannst du einmal die Bohroptimierung ausschalten, dann sollte es funktionieren.

    Gruss

    Frank

  • Teste das Programm mal. :/

    Interessanterweise werden gleiche Bohrungen an gleicher Stelle nicht doppelt ausgeführt.

    Du hattest die Lochreihen um 0,001 mm versetzt, was leider nicht zum Erfolg führte.

    Ich habe spasseshalber den Versatz nach dem NC Stop gelassen und die Lochreihen um die 2,5 mm Versatz verschoben und so werden die Bearbeitungen ausgeführt.

    Warum die Maschine einen Unterschied zwischen 0,001 und 2,5 mm macht ist mir ein Rätsel.

  • Warum die Maschine einen Unterschied zwischen 0,001 und 2,5 mm macht ist mir ein Rätsel.

    Das liegt an den internen Tolleranzen der Steuerung vermute ich. Bei uns war es so das Bohrungen an der selben Stelle einmal mit dem Bohrkopf und einmal mit dem selben Durchmesser in HSK Aufnahme, wenn vorhanden, ausgeführt wurden. Erst ab 0,1 wurde beides mit dem Bohrkopf gebohrt. Interessant wäre trotzdem das generierte Programm.

    Wenn ich dein Programm bei mir generiere werden die doppelten Bohrungen auch ignoriert und nicht an die CNC übergeben.

  • Interessanterweise werden gleiche Bohrungen an gleicher Stelle nicht doppelt ausgeführt.

    Du hattest die Lochreihen um 0,001 mm versetzt, was leider nicht zum Erfolg führte.

    Ich habe spasseshalber den Versatz nach dem NC Stop gelassen und die Lochreihen um die 2,5 mm Versatz verschoben und so werden die Bearbeitungen ausgeführt.

    Warum die Maschine einen Unterschied zwischen 0,001 und 2,5 mm macht ist mir ein Rätsel.

    Probier mal 0.1mm, kann sein das 0.01 oder 0.001 wieder auf 0 gerundet werden1

    Viele Grüße
    HomagLove

  • Hallo,

    Meldungen zeitrichtig ausgeben hat noch nie funktioniert bei Weeke Maschinen, das geht nur mit Tricks. Hatte ich schon mal etwas dazu geschrieben irgend wann.

    Stell bitte einmal das generierte Programm aus dem prg Ordner hier ein. Ich vermute du hast einen veralteten NC-Weeke der hat bei Bohroptimierung den NC-Stop ignoriert. Alternativ kannst du einmal die Bohroptimierung ausschalten, dann sollte es funktionieren.

    Gruss

    Frank

    Hier die Datei. die Endung ".mpr" muss wieder entfernt werden. Sonst hätte ich sie nicht hochladen können.

  • Das generierte Programm müsste aber eigentlich laufen, da sind je 4 Bohrungen vor und nach dem NC-Stop.

    Der NC-Weeke ist recht alt mit Version 5.235. Ich habe mal den letzten der alter 5er Serie angehängt. Ich meine die konnte man noch einfach kopieren ohne Installation. Bitte erst den original Ordner NCWEEKE umbenennen!! Dann den neuen Ordner kopieren und in NCWEEKE umbenennen.

    NCWEEKE_5_283.zip

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!