• Hallo Zusammen,

    ich möchte Werkstücke formatieren und das Werkzeug dabei in der Höhe oszillieren lassen. Ich habe dem Werkzeug eine Oszillationslänge verpasst, in WW verschiedene Werte beim "Vorschub Oszillation" ausprobiert. Es tut sich nichts.

    Im Handbuch heißt es :"Die Überlagerung der Parameter Vorschub und Vorschub Oszillation , im Zusammenhang mit dem Werkzeugdatenbankparameter Oszillationslänge (G3.2) ergeben eine Wellenbahn und müssen entsprechend abgestimmt sein".

    Kann mir das jemand erklärten?

    BG und schonmal Dank vorab, Woodie

  • Die BHC250 ist ja schon was älter und hat wohl mal ein Update auf WW6 bekommen. Ob die dann aber auch Oszillierend kann muss nicht zwingend sein. Ich meine in den Unterprogrammen für das an/abfahren sind da extra Zeilen drin wo das oszillieren geschaltet wird. Müsstest du mal prüfen ob die bei dir überhaupt vorhanden sind.


    Gruss

    Frank

  • Bei mir sind das die UPG t0xvk40 und t04hk40, wobei im hk pauschal das oszillierend mit der Zeile "OSC_OFF" ausgeschaltet wird. Im vk wird das mit P1326 gesteuert. Dort gibt es dann Zeilen mit "OSC_ON"

    Wenn du dir das generierte Programm im prg Ordner anschaust gibt es dort die Zeile L T0XVK40 , damit wird das UPG aufgerufen. Unmittelbar über dieser Zeile werden die ganzen Parameter gesetzt. Dort sollte, wenn oszillierend gewünscht ist, ein Eintrag mit P1326=1 zu finden sein.

  • Der Eintrag P1326=1 ist vorhanden.

    In der Zeile darunter steht:

    "OSC_ON"=""

    Wenn ich das richtig verstehe, müsste die Oszillation doch funktionieren. Vielleicht setze ich die Parameter Vorschub Oszillation etc auch völlig falsch ein. Kann das jemand erklären?

  • Wenn du bei G3.2 einen Wert > 0 stehen hast, im Code auch OSC_ON steht und ein Oszillationsvorschub im Woodwop angegeben ist sollte das eigentlich klappen. Gibt es in den UPG auch die Zeilen mit OSC_ON oder nur im Hauptprogramm?

    Könnte höchstens noch sein das die Maschinensteuerung mit dem Befehl nix anfangen kann und dann einfach ignoriert.

  • Du kannst meine upg zum Test erst einmal benutzen in dem du den eigenen Modus aktivierst und dort txt eingibst. Sollte das klappen dann die originalen umbenennen und bei den neuen das .txt entfernen.

    Wie gesagt Nutzung auf eigene Gefahr und Hand am Vorschubpoti!


    t0xhk40.txt

    t0xvk40.txt

  • Wenn du den eigenen Modus aktivierst werden nicht die Standard UPG verwendet die keine Dateiendung haben sondern die mit Dateiendung. Du hast so also die Möglichkeit verschiedene Unterprogramme zu verwenden ohne diese im Ordner UPG immer zu tauschen.

    Wenn du das nicht anwählen kannst muss noch der Haken in den Einstellungen gesetzt werden

  • Viele Dank für Deine Hilfe!

    Da konnte ich ja wieder Einiges dazu lernen. Leider hat es nicht geklappt. Die Maschine ist nur kurz aus der Parkposition gefahren und hat dann mit einer Fehlermeldung das Programm abgebrochen.

  • War ein Versuch wert, hätte ja auch klappen können. So bleibt dir wohl nur der Weg über Homagbohrsysteme in Erfahrung zu bringen ob die CNC das überhaupt kann und wenn ja mit welchem UPG.


    Gruss

    Frank

  • Mir fällt da gerade noch was ein. Schau dir bitte einmal die O1 Datei im a1 Ordner an. Dort muss es folgende Zeile geben

    OSZILLATI!0000000001:Oszillierend Fraesen (1=ja) / Oscillating trimming (1=yes)

    Ist dort eine 0 eingetragen bitte auf 1 ändern. Fehlt die Zeile komplett kannst du die oberhalb der letzten Zeile END neu einfügen.

  • Servus,

    bei mir hats auch ziemlich am Anfang nicht funktioniert. HOMAG hat dann einen neueren PP auf die Maschine aufgespielt.

    Anscheinend gabs da auch Versionen ohne Oszillations- Auswertung?

    Vlt. ists hier auch so...

    MfG

    Pfoti

  • pfoti möglich aber eher unwahrscheinlich. Im Hauptprogramm ist P1326=1 und es steht auch OSC_ON drin. Könnte der PP die Funktion nicht dürften diese Einträge nicht vorhanden sein.

    Meine letzte Idee, die man selber testen könnte, wäre nur noch der O1 Eintrag.

  • duketreiber bei uns war der Fehler nicht in den Programmen, sondern im PP Gen selbst.

    Frag mich aber nicht, was genau da los war, es funktioniert jetzt auf jeden Fall.

    Die Unterprogramme wurden nicht verändert, ledeglich der PP

    MfG

    Pfoti

  • Post by simoalil (June 18, 2024 at 5:11 PM).

    This post was deleted by Administrator: Kein nützlicher Beitrag / not a usefull Post (July 2, 2024 at 8:03 AM).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!