• ich habe einmal in die BMG111 bei mir im Simulator deine machine.cfg kopiert. Da kommt dann natürlich fehlende Maschinendaten. Da frisst der Simulator dann aber sogar die von unserer Venture3. Die Simulation ist dann auf allen Plätzen korrekt, sowohl wenn ich in Woodwop generierte Programme aus dem prg Ordner belege wie auch wenn ich mpr/mprx auswähle und der Simulator selber generiert. Sauger und Konsolen werden natürlich nur dargestellt wenn diese auch programmiert sind.

    Bei dir ist es so eingestellt das mit realen Maschinendaten gearbeitet wird, keine Ahnung auf welches Verzeichniss da zugegriffen wird auf einem AV PC. Bei mir habe ich dort explizit den Pfad angegeben wo was steht. Ich könnte mir vorstellen wenn der Simulator keine Sauger findet das er dann auch nix anzeigt. Wäre vielleicht noch mal einen Versuch wert das zu testen.

    Gruss

    Frank

  • Da habe ich überhaupt nix eingestellt bei den Saugern. Nachdem ich den Pfad zu den Maschinendaten und den Steuerungsdaten angegeben hatte waren alle Sauger da, auch die die ich selber angelegt hatte. Teilweise passen da die Versatzmasse nicht, aber das ist ein anderes Problem. Ich denke der Simulator liest die sauger.cfg aus und erzeug anhand der Daten 3D Modelle der Sauger.

    Gruss

    Frank

  • Hallo Frank

    Habe mal bei einer Bearbeitung ein saugervorschlag gemacht gespeichert und dann nc generiert und siehe da die sauger und Konsolen sind da und zwar nur die Konsolen und sauger die auch generiert wurden.

    O mann das das der Service nicht wusste :/ :thumbdown: :S

    Also Problem gelöst

    Vielen vielen Dank dir Frank für deine Mühe und Hilfe :!: :!: :!:

    LG Stefan

    LG Stefan

  • hallo Frank

    leider ist beim simulator noch ein schwerwiegender Fehler

    zb. bei einer normalen Formatierung die hinten beginnend ist und nach links läuft gegen uhrzeiger sinn

    fängt der fräser vorne an und auch nach links uhrzeigersinn

    also gespiegelt

    kannst du mir da auch noch helfen?

    LG Stefan

  • habs gefunden

    das mit dem spiegeln

    rechts hinten spiegelt es nicht das passt

    rechts vorne spiegelt es in y :/ warum auch immer und das werkstück wird nur hinten aufgelegt

    links hinten spiegelt es in x

    links vorne in x und y :/ und das werkstück wird nur hinten aufgelegt

    kann man das einstellen das alle 4 Felder wieder Funktionieren mit der richtigen spiegelung?

    rechts vorne sollte es ja nicht spiegeln

    links vorne ja auch nicht oder?

    lg stefan

    LG Stefan

    Edited 2 times, last by renault1 (December 29, 2021 at 6:54 PM).

  • Das auf allen Plätzen ausser Platz 1 das Werkstück gespiegelt wird ist normal. Der Nullpunkt aus WoodWop ist quasi immer an den Anschlägen.

    In der machine.cfg gibt es die Möglichkeit das Verhalten der Plätze anzupassen. Da habe ich allerdings noch nie etwas verändert, kenne also die Auswirkungen nicht wirklich. Zu finden an folgender Stelle.

    // 0 - X+ Y+

    // 1 - X- Y+

    // 2 - X+ Y-

    // 3 - X- Y-

    workplace.config = 4

    //workplace[5].orientation = 0

    //workplace[8].orientation = 1

    Zeilen mit // am Anfang sind nicht aktiv oder dienen nur der Dokumentation von Funktionen. Wenn du das wie folgt änderst sollte etwas passieren nach dem Neustart vom Simulator.

    workplace[5].orientation = 0

    workplace[8].orientation = 1

    Mit den Werten 0-3 wird dann wohl angegeben wie die Achsebefehle ausgewertet werden abweichend vom Standard. Da kannst du ja mal damit rumspielen. Aber wie gesagt, bei mir passt das alles.

    Was meinst du denn mit wird immer hinten angelegt? Wird ein Bauteil das für Platz5 ausgewählt wird auf Platz1 angezeigt, verstehe ich nicht.

    Gruss

    Frank

  • Hallo Frank

    soweit so gut :) nachdem ich die // wegmachte

    werden die sauger und werkstücke richtig angezeigt :/ <3

    hinten rechts fährt der fräser richtig gegen den uhrzeigersinn

    vorne rechts ist noch der haken drin gespiegelt y da fährt es im uhrzeigersinn das ist ja auf der maschiene auch nicht so :?:

    hinten links passt es da fährt es im uhrzeigersinn

    vorne links ist auch der haken drin gespiegelt y

    wenn ich den haken in der vorderen position rausnehme positioniert es mir die sauger falsch und die fräsung ist im Werkstück Quasi auf der falschen seite

    liegt es an meinem programm oder kann ich das auch in der machine.cfg einstellen?

    hab mal das Format programm im Anhang

    könntest du mir das anschauen?

    lg stefan

  • update ;

    jetzt muss ich nur noch den haken auf platz 5 und 8 also vorne bei spiegeln y rausmachen dan passt alles

    vielleicht weisst du da noch was

    lg stefan

    LG Stefan

  • wie bereits geschrieben sind die vorderen Plätze immer im Standard in Y gespiegelt.

    Bei den Bedingungen in deinem Format Programm fehlt noch einiges. Wenn du folgende verwendest kannst du damit völlig automatisch regeln welches Fräsmakro aktiv ist und es wird immer in die selbe Richtung gefräst.

    (_mirror AND _ymirror) OR (_nonmirror AND _nonymirror)

    (_mirror AND _nonymirror) OR (_nonmirror AND _ymirror)

    Gruss

    Frank

  • Hallo Leute,

    ich hab bei diese Verlauf mitgelesen...

    Warum ist eigentlich das Spiegeln auf der Maschine so ein großes Thema?
    Es ist doch für den CNC Bediener viel einfacher, wenn er einfach das zu den Bauteil zugeordnetes Programm aufruft.
    Und ich als Programmierer schreibe die Programme einfach genau so wie sie abgearbeitet werden müssen.
    Dann passt auch immer die Fräsrigung usw. (ohne den Aufwand mit _nonymirror;...)

    Das ein Programm exakt spiegelverkehrt ist, ist ja sowieso selten.

    -auf einer Seite hab ich Grundplatten für die Topfbänder und auf der anderen nicht.

    -Böden: Boden unten sind die Ankörnungen für die Sockelfüße/ Boden oben Positionierung für die Mauerblende.
    -...

    mfg Markus

  • Hallo Markus,

    bei uns sind fast alle Programme so das sie gespiegelt wie ungespiegelt richtig laufen. Boden Deckel ist meist identisch weil wir in der Regel immer ganze Sockelplatten mit Verstellfüssen nutzen. Bei Seiten lege ich mit einem Klick in der Komponente Lochreihe fest ob mit oder ohne Topfbänder, also ein Programm für linke und rechte Seiten.

    Gruss

    Frank

  • ...und wir arbeiten mit Rso da sind beim zeichnen alle Programme fertig zum abrufen aber hin und wieder muss ich halt auch was anderes fräsen als nur Korpus und bei komplexen sachen verwende ich halt vorher noch den Simulator

    LG stefan

    LG Stefan

  • Hallo Markus,

    bei uns sind fast alle Programme so das sie gespiegelt wie ungespiegelt richtig laufen. Boden Deckel ist meist identisch weil wir in der Regel immer ganze Sockelplatten mit Verstellfüssen nutzen. Bei Seiten lege ich mit einem Klick in der Komponente Lochreihe fest ob mit oder ohne Topfbänder, also ein Programm für linke und rechte Seiten.

    Gruss

    Frank

    Okey.
    Da musst ja dann das Programm wo du zb. die Topfbänder wegschalten möchtest auf der Maschinen öffnen?
    Wo hast du den Hinweis für den Maschienenbediener, das das Programm gespiegelt gehört?

    Ich hab da auch eine Komponente die alles spielt was irgendwie im System "Seite" möglich ist. Da ändere ich im WW nur den Einfügepunkt der Komponente und schon sind alle Bohrungen gespiegelt. :/
    Somit gibt's bei der Abarbeitung der Bauteile keine Hopalas
    > Programm rechts-gehört zu Seite rechts,....

    lg

  • ...und wir arbeiten mit Rso da sind beim zeichnen alle Programme fertig zum abrufen aber hin und wieder muss ich halt auch was anderes fräsen als nur Korpus und bei komplexen sachen verwende ich halt vorher noch den Simulator

    LG stefan

    Übergibst du da alle Programme übers RSO? oder eher nur die "Einfachen"?
    Hat RSO keine Fräser- und Abtragssimulation?
    - ist ja sonst zimlich Mühsam, wenn du die interessanten Teile ins WoodMotion laden musst

    lg


    ps. sorry für die teils blöden Fragen, aber mich interessiert die Herangehensweise von Anderen :D

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!