Posts by alha

    Servus,


    unter "C:\Program Files (x86)\HOMAG Group\woodWOP6\help"

    ist dieses pdf "mpr4x_format_enu" zu finden das ziemlich aktuell ist.


    Bis auf ORI sind alle im pdf zu finden.

    Auf den ersten Blick dürfte ORI ein interner Zähler sein der einfach alle Makros fortlaufend durchnummeriert


    1.Makro ORI="1"

    ...

    ...

    4. Makro ORI="4"

    ...


    Alfred

    Servus,


    ich würd's mal mit dem Makro ' Vektor Fräsen ' probieren , den A-Wert gleich wie in der WZDB eingeben, C-Wert je nach Startrichtung und den Haken bei ' C-Achse mitführen ' setzen. Einstellungen sind wahscheinlich hinterm grüne Kreuz versteckt.


    Alfred

    Servus,


    als erstes den Startpunkt neu definiert und der Fehler war behoben.

    Datei unter neuem Namen gespeichert und beide Dateien mit einem Texeditor (Megarepl) verglichen.

    Einige Unterschiede im Kopf der Datei - Weeke/Homag/Woodwopversion ..

    unter <105 \Konturfraesen\ der Unterschied mit der Richtung


    die mpr Formatbeschreibung sollt hier zu finden sein


    C:\Program Files (x86)\HOMAG Group\woodWOP6\help\mpr4x_format_enu.pdf


    wir haben zu WW5 Zeiten teilweise mpr aus einer Datenbank erstellt da kennt man dann solche Fehler wenn man falsche Daten in die mpr schreibt


    LG

    Alfred

    So könnte man es machen.


     



    Spiralförmige Hohlkehlenfräsung 1.mprx


    Ich hab die Kegelfläche auf der die Spirale liegt erstellt

    halbe Kegelfläche für Schruppen erstellt

    Spirale in 2 Teile geteilt

    die rechten Hälfte der Spiale kopiert und um 90° gedreht

    schräger Trennschnitt da Achse nicht ortogonal

    die zwei Teile um 90° verdreht wieder verbinden ( Länge um Sägeschnittbreite nicht korrigiert)


    Besser wär neu im CAD erstellen:


    Quader mit 100x100x415mm

    Spirale mittig mit der Achse ortogonal

    Kegelfläche auf der die Spirale liegt
    in 2 Hälften teilen ( 2. Hälfte um 90° drehen )

    in Woodwop bearbeiten


    viel Spass

    Alfred

    Hallo,


    Fragen über Fragen ...


    - wie wird die X und Y Position vom Ausschnitt in der Extern.mpr angegeben? Mit Variablen / Kommentar / Konturpunkt / .. ?

    Annahme 1: mit Variablen z.B.: AusschX=l AusschY=100


    - wie wird ' unten ' in der Extern.mpr angegeben? ' unten ' ist die Kante mit dem Ausschnitt ?

    Annahme 2:
    AusschX=0 --> Ausschnitt an der linken Kante --> AusschY liegt zwischen 0 und b

    AusschX=l --> Ausschnitt an der rechte Kante --> AusschY liegt zwischen 0 und b

    AusschY=0 --> Ausschnitt an der vorderen Kante --> AusschX liegt zwischen 0 und l

    AusschY=b --> Ausschnitt an der hinteren Kante --> AusschX liegt zwischen 0 und l


    Annahme 3:

    Variablen AusschX und AusschY sind in der Komponente und in der Extern.mpr vorhanden

    Komponente einfügen mit Position 0,0


    Sieh dir die mpr an ob die Richtung stimmt :/


    Alfred

    Hallo,


    Welches Fenster ?

    Nach welchem Befehl passiert das ?

    Wenn du ESC drückst läuft Woodwop weiter ?

    Hattest du einen zweiten Monitor verwendet und jetzt nicht mehr ?


    Teste mal im Menü Ansicht - Fensteranordnung zurücksetzen ( Aanzicht - Rangschikking vensters resetten)


    Alfred

    Hallo Malte,


    hast du mal ein Beispiel durch was sich das Werkzeug änden soll.

    Verschiebung XY oder Z ?

    Die Lösung liegt vielleicht in einem anderen Aufbau der Komponente :/


    Gruß

    Alfred

    Hallo Stefan,


    doppelklick öffnen geht aber das programm ist nicht da

    wie gesagt nur wenn ich ich dann in woodwop das programm öffne ist es da


    hab ich das richtig verstanden, auch wenn die mpr in einem anderen Ordner liegt funktioniert der Start nicht ?


    Schau mal in regedit.exe nach was da eingetragen ist.


    - Starten von Regedit Start / ausführen / regedit

    - in der oberen Zeile eigeben: Computer\HKEY_CLASSES_ROOT\mprxFileType\shell\woodWOP6\command


    dort sollte eingetragen sein

    "C:\Program Files (x86)\HOMAG Group\woodWOP6\woodwop.exe" "[open %1]" -@="%APPDATA%\Homag Group\woodWOP.dbg"


    wenn ich bei mir das "[open %1]" lösche passiert das gleiche wie bei dir .


    LG

    Alfred